Announcement

Collapse
No announcement yet.

http://opensource.wandisco.com/rhel/7 git version has unresolvable dependency

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • http://opensource.wandisco.com/rhel/7 git version has unresolvable dependency

    Hi all,

    Firstly, thanks for making modern git versions available to the OpenSource community. And an even bigger thanks goes out to the team for making them available via yum, zypper, and apt repositories. This makes for easy and scalable deployment on many Linux assets.

    While I've been using these repos for many years and they've been high quality, this time I'm getting an unresolvable dependency with the the latest git RPM package.
    http://opensource.wandisco.com/cento...421.noarch.rpm

    Specifically:
    Error: Package: git-2.20.1-1.WANdisco.428.x86_64 (WANdisco-git)
    Requires: perl(MediaWiki::API)

    Same error using CentOS 7.6 and CentOS 6.10.

    After installing the appropriate wandisco-git-release package, the next step is to yum install git or git-all or git-gui depending on needs.
    The installation all produce the above error.
    I've enabled the EPEL repo, which sometimes has these types of dependencies, but no luck.
    I've searched for the appropriate perl-MediaWiki-API RPM to no avail.

    Is this a build dependency problem with git-2.20.1-1.WANdisco.428? Or can anybody tell me what repo provides the correct perl-MediaWiki-API RPM?

    Thanks!




  • #2
    Thank you for your praise.

    Let us look into the error you're seeing - very strange.

    Comment


    • #3
      Update:

      Sorry, I think I provided the wrong link above.
      I can do "yum install http://opensource.wandisco.com/centos/7/git/x86_64/git-all-2.19.2-1.WANdisco.421" on a clean system with no problem.

      The problem comes in when I try to do "yum install git-all" which tries to grab the 2.20 version. Oddly, I cannot find this version in your repo.
      {root@hostname}{/root}# yum -q list available git-all
      Available Packages
      git-all.noarch 2.20.1-1.WANdisco.428 WANdisco-git

      Thinking it may be something wrong with my cache, I've done a "yum clean all" and "rm -rf /var/cache/yum" followed by "yum makecache" and still get the 2.20 version. I've also tried several other machines, same result.

      Yet I do not see the 2.20 version here:
      http://opensource.wandisco.com/centos/7/git/x86_64/

      Doing more digging, one other person ran into this same error:
      https://superuser.com/questions/1407...git-on-centos6


      So... Could the repodata in your repo be corrupted? Let's look.

      Digging into this file:
      http://opensource.wandisco.com/cento...primary.xml.gz

      I see...

      Code:
      <package type="rpm"><name>git</name><arch>src</arch><version epoch="0" ver="2.20.1" rel="1.WANdisco.428"/><checksum type="sha256" pkgid="YES">18623003895adcd97c454d3853de0c928ae42e8e14c4027e99174e987e3627f9</checksum><summary>Fast Version Control System</summary><description>Git is a fast, scalable, distributed revision control system with an
      unusually rich command set that provides both high-level operations
      and full access to internals.
      
      The git rpm installs the core tools with minimal dependencies.  To
      install all git packages, including tools for integrating with other
      SCMs, install the git-all meta-package.</description><packager/><url>http://www.wandisco.com</url><time file="1548075039" build="1548071237"/><size package="11611608" installed="11645375" archive="11646984"/><location href="git-2.20.1-1.WANdisco.428.src.rpm"/>
      Hope this helps.

      Comment


      • #4
        Edit: meant to say... I can do "yum install git-all-2.19.2-1.WANdisco.421" on a clean system with no problem.

        Comment


        • #5
          This is odd too.

          {root@hostname}{/root}# yum -q list available git-all-2.19.2
          Available Packages
          git-all.noarch 2.19.2-1.WANdisco.424 WANdisco-git

          There is no .424 version, only .421... in the repo here:
          http://opensource.wandisco.com/centos/7/git/x86_64/

          Which further points to corrupted repodata files.

          Comment


          • #6
            I have the same issue. Seems that version 2.20-1 rpm was pulled from the repo but when I update my server it still wants to upgrade to 2.20-1 and fails.

            ---> Package git.x86_64 0:2.20.1-1.WANdisco.428 will be an update
            --> Processing Dependency: perl(MediaWiki::API) for package: git-2.20.1-1.WANdisco.428.x86_64
            ---> Package perl-Class-Factory-Util.noarch 0:1.7-15.el7 will be installed
            ---> Package perl-DateTime-Format-Strptime.noarch 0:1.5400-2.el7 will be installed
            --> Finished Dependency Resolution
            Error: Package: git-2.20.1-1.WANdisco.428.x86_64 (WANdisco-git)
            Requires: perl(MediaWiki::API)
            You could try using --skip-broken to work around the problem
            You could try running: rpm -Va --nofiles --nodigest


            Comment


            • #7
              This is great information - thank you. I'll let our internal repo folks know! Cheers!

              Comment

              Working...
              X