I download the latest git package for Mac OSX. The file I downloaded is: git-2.0.1-intel-universal-snow-leopard.dmg I run that ok, and I get a directory with the file named: git-2.0.1-intel-universal-snow-leopard.pkg The install goes fine, but then with I attempt to run: git --version, I get : Illegal Instruction: 4 I searched Google for this error message and found the following link on Stackoverflow [url]http://stackoverflow.com/questions/14268887/what-is-the-illegal-instruction-4-error-and-why-does-mmacosx-version-min-10[/url] From what I can tell from this set of threads, git needed to be compiled with a special directive that will allow it to run on older versions of OSX. However, the package name of the install file says universal-snow-leopard, which is OSX version 10.6, or the dot rev before what I am running (10.7.x). I'm not sure I believe what was written on stackoverflow, and if the only option for me is to recompile git with this control setting, then I'm probably not going to be using git on my old Macbook Air (I cannot update OSX to any later version - this was decided by Apple, not me). Any thoughts from anyone? Was git compiled with the wrong directives?